Cyma m4A1 CQB mag feed

Hi, my cyma has a problem, it was working like a dream until it stopped feeding when you pull back the priming slide, I opened the blaster, everything seemed okay but the mags motor was rusted through.Today I got the new mag, testing the new mag (have not opened it) doesn’t feed either. So I decided finally, to come to the forum so that I may be able to skip spending like 60 bucks on a tech having a look at it, and then spending on a fix. Anyone have a solution?

1 Like

Check your mag terminal wiring. Use MK1 eyeball for loose connections. Use a multimeter to check if voltage is getting to the terminal.

If ok, check your mag for same.

1 Like

CYMA do a pretty tidy job on their wire routing, it’s not likely to be a pinched mag wire… more likely to be a wire off one of the terminal springs. Easy to see with a multimeter as Maiphut suggests, and dead easy to fix… IF you have a soldering iron.

If you don’t make have one I’d suggest making it your next accessory purchase… you do a lot of resoldering on these things. :joy:

Don’t discount the mag though… just because it’s new doesn’t guarantee it’s fault free. Test it out with a 9v battery out of the blaster. If it spins up then you’ll know where to go looking.

Did you get a CYMA mag? Gen 8 mags fit but won’t feed

Hope you have solved the issue you encountered. Sharing my dummy way to troubleshoot similar issues…

Identify the potential faulty parts, it can be the broken wires or the mag.

You have got a new mag and tried already, the chance the issue happen on the mag is low.

You may have tried already, check if there are any cuts around the wiring outside. If you don’t have soldering tool, you can try to contact the wires back to see if it still work.


Haven’t tried anything, I am going to get the gearbox out today… don’t think I have a multimeter, have a soldering iron though so that’s useful… can make a makeshift one! Led plus a resistor and a male to male wire see if it lights up, the brand new multimeter!

Definitely a cyma mag, looks exactly the same as the old one, just new.

1 Like

You can check that the mag is working using a 9v battery. Just put the battery on the terminals and see if the mag motor spins.

Does the mag seat correctly in the mag well?

Does sound like a wire to one of the contacts could be broken. As suggested, use a multimeter to check voltage at the contacts in the mag well

1 Like

I’d check the mag terminals before ripping out the gearbox… if they check out okay there’s no need to disassemble.

Does it feed gels when you trigger it? If it’s feeding under use but not mag priming, it could just be a wire off your priming switch.

I can vouch for the fact that they’re flimsy beyond belief.


It feeds when you put the blaster on full auto

1 Like

Both mags work, even the one with the rusted motor, it is the blaster which has the issue

1 Like

Okay, confused now…

Is the issue that it doesn’t feed on semi?

1 Like

Yes and no, it only feeds in full auto and it takes five seconds which A, makes it inconvenient and B, annoying. It fires gels on semi auto after that 5 seconds, but once you get the mag to half full it stops, so you have to switch it back to full auto feed it for 5 seconds and then it when you flip it back to semi auto it feeds until the mag gets to 1 quarter full, then you have to flip it upside down. So yes this is a very long explanation, yes the issue is it does feed on semi auto, but the other reason is that it is annoying. Sorry in advance if this is too much information or if it seems I am angry or for any other reason. Thank you all for your help so far.

No need to apologise, all good.

I seriously can’t think what the fault is with your CYMA I’ve never heard of a blaster with a fault that causes it to take 5 seconds to feed.

Feed issues are usually either mechanical or electrical, usually the latter. You know what to do for the former… it’s all up there :point_up_2:

An example of a mechanical issue is the rubber nozzle moving on the nozzle shaft. If it shifts forward, it can prevent gels getting into the t piece. It can sometimes show itself intermittently, this happened to a VZ Scorpion of mine recently and was tricky to find. Again, not time based though… random.

Got me stumped, based on your description of what it’s doing. Hopefully someone on here will have some idea what your possessed CYMA us doing and be able to help you out. :man_shrugging:


Yeah, kinda the reason I came here… definitely electrical though as the motor in the mag doesn’t run when pulling the priming handle. I may have gotten a dogey cyma! Too bad I can’t get a replacement seeing as the warranty is only 30 days long and it’s been a year.

Definitely possessed though! Rare possessed cyma here! Get your rare possessed cyma here… It’s my only possessed object, should take it to a church! (All jokes)

Broken wire in the circuit. Probably shaking it reconnects the wire at the break. Wouldn’t surprise me if it is cracked where the mag prime diode is soldered to feed circuit


Never mind I understand… I will check it out

Yeah, that’s what I thought at first too… but I really don’t get where the 5 second delay comes into the picture. :exploding_head:

That’s how long it takes before he gets mad and gives it a shake